Office 365 - Exchange email service degradation
Incident Report for Sentrian's System Statuses
Resolved
This incident was resolved overnight by Microsoft. If you encounter any further problems please contact our service desk.
Posted Nov 19, 2019 - 21:45 AEST
Update
Microsoft are continuing to work on this incident and have advised that internal email with attachments may also be affected. The next update to this status page will be tomorrow morning.
Posted Nov 19, 2019 - 17:50 AEST
Identified
Microsoft have reported an incident EX196121 affecting receipt of external email. We have had reports from customers of this issue also affecting sending of emails directly from photocopiers or applications. The next ETA for an update from Microsoft is after 5:30pm (UTC+10).
Posted Nov 19, 2019 - 15:29 AEST
This incident affected: Microsoft - Office 365.